Connection failed for 'AzureDNIG-REPO'. Please check your connection


#1

I am new to DNIF and followed the document & successfully implemented DNIF. But whenever I click on the Top menu, getting error as “Connection failed for ‘AzureDNIG-REPO’. Please check your connection.”

I have allowed any from outside to Inside & inside to Outside as well. But still the error is same.

Installed in Azure - Ubuntu Linux Version.


#2

Hi @pcclones, I think the issue is similar to the one discussed in the thread - Connection Unsuccessful

Let me know if the shared thread helps :grinning:


#3

Thanks for the reply and here is the output of the logs:

localadmin@dnif:/opt/a10$ sudo docker-compose logs
Attaching to comp-dnif-a10
comp-dnif-a10 | * Stopping enhanced syslogd rsyslogd
comp-dnif-a10 | …done.
comp-dnif-a10 | * Starting enhanced syslogd rsyslogd
comp-dnif-a10 | …done.
comp-dnif-a10 | Starting redis-server: redis-server.
comp-dnif-a10 | Generating a 2048 bit RSA private key
comp-dnif-a10 | …+++
comp-dnif-a10 | …+++
comp-dnif-a10 | writing new private key to ‘/dnif/9dDWszmqjA4gOBLs/ssl/dnif_https_API.key’
comp-dnif-a10 | -----
comp-dnif-a10 | Generating a 2048 bit RSA private key
comp-dnif-a10 | …+++
comp-dnif-a10 | …+++
comp-dnif-a10 | writing new private key to ‘/dnif/9dDWszmqjA4gOBLs/ssl2/dnif_https_listener.key’
comp-dnif-a10 | -----
comp-dnif-a10 | * Starting Elasticsearch Server
comp-dnif-a10 | sysctl: setting key “vm.max_map_count”: Read-only file system
comp-dnif-a10 | …done.
comp-dnif-a10 | * Restarting periodic command scheduler cron
comp-dnif-a10 | * Stopping periodic command scheduler cron
comp-dnif-a10 | …done.
comp-dnif-a10 | * Starting periodic command scheduler cron
comp-dnif-a10 | …done.
comp-dnif-a10 | ERROR:root:DB is not up, waiting
comp-dnif-a10 | ERROR:root:DB is not up, waiting
comp-dnif-a10 | ERROR:root:DB is not up, waiting
comp-dnif-a10 | --> [+] does not exist, Inserting…!!
comp-dnif-a10 | ACCEPT all opt – in * out * 127.0.0.1 -> 0.0.0.0/0
comp-dnif-a10 | --> [+] does not exist, Inserting…!!
comp-dnif-a10 | DROP tcp opt – in * out * !127.0.0.1 -> 0.0.0.0/0 tcp dpt:826
comp-dnif-a10 | --> [+] does not exist, Inserting…!!
comp-dnif-a10 | --> [+] does not exist, Inserting…!!
comp-dnif-a10 | DROP tcp opt – in * out * !127.0.0.1 -> 0.0.0.0/0 tcp dpt:8240
comp-dnif-a10 | --> [+] does not exist, Inserting…!!
comp-dnif-a10 | --> [+] does not exist, Inserting…!!
comp-dnif-a10 | --> [+] does not exist, Inserting…!!
comp-dnif-a10 | --> [+] does not exist, Inserting…!!
comp-dnif-a10 | --> [+] does not exist, Inserting…!!
comp-dnif-a10 | --> [+] does not exist, Inserting…!!
comp-dnif-a10 | tput: No value for $TERM and no -T specified
comp-dnif-a10 |
comp-dnif-a10 | ____ _ _ ___ _____ __ __
comp-dnif-a10 | | _ | \ | |_ | | \ \ \
comp-dnif-a10 | | | | | | || || |
\ \ \
comp-dnif-a10 | | |
| | |\ || || | / / / /
comp-dnif-a10 | |
/|| _||| // //
comp-dnif-a10 |
comp-dnif-a10 | Server is now running…
comp-dnif-a10 | Please visit DNIF console at : http://go.dnif.it/
comp-dnif-a10 | tput: No value for $TERM and no -T specified
comp-dnif-a10 |
comp-dnif-a10 | /usr/lib/python2.7/dist-packages/supervisor/options.py:297: UserWarning: Supervisord is running as root and it is searching for its configuration file in default locations (including its current working directory); you probably want to specify a “-c” argument specifying an absolute path to a configuration file for improved security.
comp-dnif-a10 | 'Supervisord is running as root and it is searching ’
comp-dnif-a10 | 2019-03-14 09:02:36,189 CRIT Set uid to user 0
comp-dnif-a10 | 2019-03-14 09:02:36,200 CRIT Server ‘unix_http_server’ running without any HTTP authentication checking


#4

localadmin@dnif:~$ sudo supervisorctl
supervisor> restart din ingestor
din: ERROR (no such process)
ingestor: ERROR (no such process)
din: ERROR (no such process)
ingestor: ERROR (no such process)
supervisor> status
supervisor>
supervisor>